Due to ongoing debates about the use and misuse of the “German Support” category to the detriment of users who don’t speak German, the creation of new topics on the category has been closed. Thus, this category is now read-only.

Empfehlung Tür/Fenster Sensoren?
C

@Revo
Vielen Dank für die Bilder, das probiere ich gleich mal aus.

@V1per
Revo hat das Kabel ja an die bestehende Antenne angelötet dessen genaue Länge (ausgerollt) ja nicht bekannt ist. Nach meinem Verständnis sollte die Gesamtlänge ja 17,2 cm sein.

read more

Questions about the release of v0.9

Inpossible to install dependency "SQLITE3"
C

@woodhouse can you open the wiki without access data?! i get this popup? 0_1655746259337_acf5348b-6a73-48d9-8816-4ec91b04a208-image.png

read more
Questions about the Forum and Pimatic.org
Mark all threads as read?

Yes this works, buit only for the thread listed under this unread button.
Not for older Threads.

What i would like to do in fact is to once set all threads to read so that only those threads appear bold where since that point posts where made or new threads.

read more
any trouble with your setup, linux, pi etc.
Pimatic-Telegram problems connection with BOT
L

Hi. I had a running Bot with Pimatic, but since i have installed the new Update, and i have deleted some old Devices, and Rules.

And since this action, i dont recieve Messenges from the Bot.

I have already deleted and re installed the Telegram app, but the Pimatic docs dont work any more, so i used the NPM tutorial:
[https://www.npmjs.com/package/pimatic-telegram](link url)

The Bot Token and the chat id are correct, i have tested it with https://api.telegram.org/bot…/sendmessage?chat_id=…&text=Alarm
I also have installed a recipients.

I also tested rebooting after installation and reboot after update.

Have anybody a idea?
Thanks a lot :-)

Here is my config file:
{
“settings”: {
“locale”: “en”,
“debug”: false,
“logLevel”: “info”,
“httpServer”: {
“enabled”: true,
“port”: 80
},
“database”: {
“deviceAttributeLogging”: [
{
“deviceId”: “",
“attributeName”: "”,
“type”: “",
“interval”: “0”,
“expire”: “7d”
},
{
“deviceId”: "”,
“attributeName”: “",
“type”: “continuous”,
“interval”: “5min”,
“expire”: “7d”
},
{
“deviceId”: "”,
“attributeName”: “temperature”,
“type”: “number”,
“expire”: “1y”
},
{
“deviceId”: “",
“attributeName”: “humidity”,
“type”: “number”,
“expire”: “1y”
}
],
“messageLogging”: [
{
“level”: "”,
“tags”: [],
“expire”: “7d”
},
{
“level”: “debug”,
“tags”: [],
“expire”: “0”
}
]
},
“authentication”: {
“secret”: “xxxxxxxxxx”
},
“httpsServer”: {},
“cors”: {},
“gui”: {}
},
“plugins”: [
{
“plugin”: “cron”
},
{
“plugin”: “mobile-frontend”
},
{
“plugin”: “dht-sensors”,
“active”: true
},
{
“plugin”: “gpio”,
“active”: true
},
{
“shell”: “”,
“plugin”: “shell-execute”,
“active”: true
},
{
“apiToken”: “+++++++++++++++”,
“recipients”: [
{
“name”: “MyAwsomePimatic_bot”,
“userChatId”: “+++++++++++”,
“enabled”: true,
“admin”: true
}
],
“plugin”: “telegram”,
“active”: true,
“host”: “api.telegram.org”,
“debug”: true
}
],
“devices”: [
{
“secret”: “change_me_now!”,
“auth_timeout”: 5,
“id”: “++++++++++”,
“name”: “MyAwsomePimatic_bot”,
“class”: “TelegramReceiverDevice”
},
{
“type”: 22,
“pinType”: “BCM GPIO”,
“pin”: 25,
“xAttributeOptions”: [],
“id”: “test”,
“name”: “DHT-22 IN BOX”,
“class”: “DHTSensor”,
“interval”: 60000
},
{
“gpio”: 4,
“id”: “abluft”,
“name”: “Abluft”,
“class”: “GpioSwitch”
},
{
“gpio”: 0,
“id”: “umluft”,
“name”: “Umluft”,
“class”: “GpioSwitch”
},
{
“type”: 22,
“pinType”: “BCM GPIO”,
“pin”: 13,
“xAttributeOptions”: [],
“id”: “dht-22-out-box”,
“name”: “DHT-22 OUT BOX”,
“class”: “DHTSensor”,
“interval”: 60000
}
],
“rules”: [
{
“id”: “reboot”,
“name”: “reboot”,
“rule”: “when its 24:00 then execute “/home/pi/Desktop/Reboot.sh””,
“active”: true,
“logging”: true
}
],
“pages”: [
{
“id”: “favourite”,
“name”: “Favourites”,
“devices”: [
{
“deviceId”: “test”
},
{
“deviceId”: “abluft”
},
{
“deviceId”: “dht-22-out-box”
}
]
}
],
“groups”: [],
“users”: [
{
“username”: “admin”,
“password”: “xxxxxxxxxx”,
“role”: “admin”
}
],
“roles”: [
{
“name”: “admin”,
“permissions”: {
“pages”: “write”,
“rules”: “write”,
“variables”: “write”,
“messages”: “write”,
“events”: “write”,
“devices”: “write”,
“groups”: “write”,
“plugins”: “write”,
“updates”: “write”,
“database”: “write”,
“config”: “write”,
“controlDevices”: true,
“restart”: true
}
}
],
“variables”: []
}

One Error Code i get after restart:
error [pimatic]: Unexpected token {

Edit:
I have already found the problem. I had the wrong NPM and NodeJs installed. I have deleted pimatic, and i have installed the program, and it is running :)

read more

Looks like your connection to pimatic forum was lost, please wait while we try to reconnect.