• D

    Another solution is to use a accelerometer. See also the mysensor forum:


    The code is a bit more complex but it is very easy to position the sensor and the output is more accurate when the consumption is very low more accurate.

    I have got it running for over half a year now this way and no problems.

    Eine andere Lösung ist, einen Beschleunigungsmesser zu verwenden. Siehe auch das mysensor forum:


    Der Code ist ein bisschen komplexer, aber es ist sehr einfach, den Sensor zu positionieren und der Ausgang ist genauer, wenn der Verbrauch sehr niedrig ist.

    Ich habe es für mehr als ein halbes Jahr auf diese Weise und keine Probleme.

    posted in Support in Deutsch read more
  • D

    @Gleno0h the Dutch forum was basically ironically said… so no worries

    posted in Announcements read more
  • D

    @mwittig Looks like a feasible solution. Still if we have a message containing an object containing multiple name + values, it should be not that hard to process and set the corresponding value?

    posted in Plugins read more
  • D

    @mwittig Ah did not notice that node was there, very convenient. But then you should be able to set the variable name in the Msg when sending it out via the set variable link? Or is this already possible.

    posted in Plugins read more
  • D

    So now we see automatically the point why the Dutch are better (besides footbal) than the German… :stuck_out_tongue_winking_eye:

    posted in Announcements read more
  • D

    As far as I can see most of the questions asked in the German category could have easily been asked in the english languange. Maybe with a little bit of effort. For me it is no problem reading them, but it will make searching within the forum very difficult. So I would say take some effort, translate into english and if you can not find the right word or sentence write it in German. Maybe we should start a Dutch section as well, as many users are Dutch…

    posted in Announcements read more
  • D

    Hi this is my current setup for the mi flora
    I am using a python script to read the data from the various sensors (3 plants). The output of the script is converted into a msg format in a function:
    var tokens = msg.payload.split("\n");
    msg.payload = {
    fw : tokens[1],
    Name : “Ficus Benja”,
    temp : tokens[5],
    Moisture : tokens[7],
    Light : tokens [9],
    Conductivity : tokens [11],
    Battery : tokens [13]
    msg.topic = "MiFlora/FicusBenja"
    return msg;
    This is sent to my influx database, MQTT gateway and if the moisture level is to low to telegram. (So my wife can water the plants ;-) )
    The MQTT message is now used in pimatic as a MQTT Sensor:



    The question is indeed whether you can set the attributes?

    posted in Plugins read more
  • D

    @mwittig I have tested the set value as well. It works very well. A point of improvement is maybe some “content” testing. By accident I have parsed an object as payload. The value in Pimatic is still set as [object]. I think this will lead to problems in Pimatic if values are set which are not realistic?

    Additionally: Would there be an option to set a parameter with multiple attributes with one message? For example I use node-red to read my MiFlore plant sensors via a script. These are now forwarded via a simple MQTT output in which the complete object with data could be parsed.

    MiFlora/FicusBenja : msg.payload : Object
    fw: "3.1.4"
    Name: "Ficus Benja"
    temp: "23.7"
    Moisture: "45"
    Light: "160"
    Conductivity: "504"
    Battery: “99”

    I have now have a MQTT sensor with multiple attributes which are set by receiving the MQTT message.

    posted in Plugins read more
  • D

    @mwittig I have removed the socketio package and removed the settings from the websocket node. I was playing with these to connect to pimatic so some old settings were still activated. Let us hope this was the cause of conflict…

    Update, still running now. So I think existing (web)socket(io) were conflicting with the plugin…But changes are of course low that someone else is playing with these and connecting to pimatic…;-)

    posted in Plugins read more
  • D

    @mwittig said in Node-red for pimatic available:

    Which browser are you using?

    I am using various browsers…but mainly firefox and chrome

    It might be server-side issue though. Check memory usage and the ulimits for the user running node-red. Do you start node-red from the command line by typing “node-red” or does the apt package installation comes along with some sort of service wrapper?

    I have remove the apt-get package and installed it via npm to have more control. I have started it via the console but also as a service via a script (raspberry script for node-red)

    This also happens after a while of running. I did not look into it but can I increase the debug level of node-red?

    node-red has a verbose option which you can use if you start node-red from the command line: node-red -v.
    Ok I will run a console with this option to see the output…
    18 Jul 22:10:03 - [info] Stopped flows
    18 Jul 22:10:03 - [info] Starting flows
    18 Jul 22:10:03 - [info] [socketio-config:12fd9073.7fb54] Created server bind to Node-red port
    18 Jul 22:10:03 - [info] [inject:6f383581.b72cec] repeat = 300000
    18 Jul 22:10:03 - [info] [inject:Weather query] repeat = 300000
    18 Jul 22:10:03 - [info] [inject:bf2cffb.d7efd] repeat = 30000
    18 Jul 22:10:03 - [info] [inject:92f6524a.3197b] repeat = 300000
    18 Jul 22:10:03 - [info] [inject:a878321d.411298] repeat = 900000
    18 Jul 22:10:03 - [info] Started flows
    18 Jul 22:10:03 - [info] [mqtt-broker:cd46eff.89e6b1] Connected to broker: mqtt://
    18 Jul 22:10:03 - [error] [tcp request:e69c8507.4b01a8] connect failed

    Can you pelase also let me know which non-core nodes (additional packages) you have installed? It might be a combination of packages causing the issue.
    Maybe socketio is doing the trick…

    posted in Plugins read more

Looks like your connection to pimatic forum was lost, please wait while we try to reconnect.