• S
    Swen

    Check via console and command top. Check which process really exhaust you cpu. If it’s really PHP then you have a bug in PHP. Normally php don’t need so much power on one user action. By the why post your top here and please tell me which Pi version are you using (1,2,3…) and version of PHP. Also tell me if you use bash on first line and how you execute script.

    posted in Howto ... read more
  • S
    Swen

    You have my attention. Start asking with your issues.

    posted in General Discussion read more
  • S
    Swen

    There is another php version up and running.

    posted in Howto ... read more
  • S
    Swen

    syntax error, unexpected ‘=’ in /etc/php5/cli/conf.d/20-apcu.ini on line 8

    That makes me headache… Can you deactivate apcu module and try again?

    Otherwise, how did you create your php file? Can you post your php via paste bin or can you upload you php?

    posted in Howto ... read more
  • S
    Swen

    sudo php presence.php 64:BC:0C:42:91:79
    PHP: syntax error, unexpected ‘=’ in /etc/php5/cli/conf.d/20-apcu.ini on line 8

    And again… If you are using my script its working like bash and you don’t need to start php parser before.

    Don’t use php /home/pi/ don’t user php presence.php fi you have this: #!/usr/bin/php on first line it will be execute like a bash script and the parser will be request at start of this script.

    posted in Howto ... read more
  • S
    Swen

    #!/usr/bin/php did you have this on first line??? if yes then you don’t need php! you need only path to script and the script must be executable.

    posted in Howto ... read more
  • S
    Swen

    What does it mean if you write “i start the script”.

    Are you starting the php script and get this error? Are you get this error with more information? Where are you get this error?

    posted in Howto ... read more
  • S
    Swen

    Awesome. Thanks for your feedback.

    posted in Howto ... read more

Looks like your connection to pimatic forum was lost, please wait while we try to reconnect.