• S
    shgmongo

    @mwittig
    I tried your solution, but it doesn´t work. I don´t know why. Maybe it is my fault.

    @Jos-Hendriks
    I will try your solution the next days. Thanks to you for your docker image. Pimatic works on my pi as a docker. I have now my own image, where everything is fine until the time zone.

    posted in Howto ... read more
  • S
    shgmongo

    @Jos-Hendriks

    I have installed pimatic via docker with your image. Everything is working fine.
    But the cron-timezone (UTC) on docker is different to the timezone on the hub (CEST).
    How can I fix it?

    Sebastian

    posted in Howto ... read more
  • S
    shgmongo

    @Gleno0h
    I set nothing…

    {
      "settings": {
        "locale": "de",
        "httpServer": {
          "enabled": true,
          "port": 80
        },
        "database": {
          "deviceAttributeLogging": [
            {
              "deviceId": "*",
              "attributeName": "*",
              "type": "*",
              "interval": "0",
              "expire": "7d"
            },
            {
              "deviceId": "*",
              "attributeName": "*",
              "type": "continuous",
              "interval": "5min",
              "expire": "7d"
            },
            {
              "deviceId": "*",
              "attributeName": "temperature",
              "type": "number",
              "expire": "1y"
            },
            {
              "deviceId": "*",
              "attributeName": "humidity",
              "type": "number",
              "expire": "1y"
            }
          ],
    

    posted in Howto ... read more
  • S
    shgmongo

    Hi I have a problem with pimatic-cron.

    The time cron uses is utc. I want to use utc+2h. How can I change it?
    0_1503157804664_cron.PNG

    I have run raspi-confi option 4 allready,but nothing changed.

    pi@raspberrypi:~ $ sudo raspi-config
    
    Current default time zone: 'Europe/Berlin'
    Local time is now:      Sat Aug 19 17:44:39 CEST 2017.
    Universal Time is now:  Sat Aug 19 15:44:39 UTC 2017.
    

    Sebanstian

    posted in Howto ... read more
  • S
    shgmongo

    @Gleno0h
    Allready done. But nothing changed.
    Could be the problem, that I use pimatic in a docker enviroment?

    pi@raspberrypi:~ $ sudo raspi-config
    
    Current default time zone: 'Europe/Berlin'
    Local time is now:      Sat Aug 19 17:44:39 CEST 2017.
    Universal Time is now:  Sat Aug 19 15:44:39 UTC 2017.
    
    
    

    posted in Howto ... read more
  • S
    shgmongo

    Hello,

    i found the problem. The rule uses UTC time and not Local time. Therefore they are two hour difference.
    Wenn I want to turn on the light at 16 o´clock, the rule must have the time 14 o´clock. How can I chnage this?

    pi@raspberrypi:~ $ sudo dpkg-reconfigure tzdata
    
    Current default time zone: 'Europe/Berlin'
    Local time is now:      Sat Aug 19 15:54:18 CEST 2017.
    Universal Time is now:  Sat Aug 19 13:54:18 UTC 2017.
    

    0_1503152844767_cron.PNG

    posted in Howto ... read more
  • S
    shgmongo

    Hello,
    I have a problem with rules. I have “installed” Pimatic via docker on my raspberry.

    Everythings work, but the rules are not executed. There is also no failure entry in the messages log.

    I can turn on and of all my lights with “alle-tasten” on my Favorites. The variable is $alle-tasten.state(attribute).

    The rule is

    {
          "id": "lampenaus22",
          "name": "LampenAus22",
          "rule": "when its 22:05 then turn alle-tasten off",
          "active": true,
          "logging": true
        },
    

    Is something wrong with my rule?

    Sebastian

    posted in Howto ... read more
  • S
    shgmongo

    @Jos-Hendriks

    Maybe that would help with my issue.
    Its boring that i could Not run Pimatic and Magie Mirror on one pi.

    posted in Howto ... read more
  • S
    shgmongo

    @Gleno0h

    Which code or file do you mean? The one I start pimatic?
    I have my own confg file for pimatic. But I can save it but i cannot build a docker.

    root@c8d71f97adb0:/# pimatic.js
    coffee-cache: compiling coffee-script file "startup.coffee"...Done
    19:53:55.716 2017-07-11 Tuesday
    19:54:04.732 [pimatic] Starting pimatic version 0.9.39
    19:54:07.815 [pimatic, ppm] 2.15.12
    19:54:07.921 [pimatic] Loading plugin: "pimatic-cron" (0.8.8)
    19:54:08.601 [pimatic] Loading plugin: "pimatic-mobile-frontend" (0.9.11)
    19:54:09.672 [pimatic-cron] the time is: Tue Jul 11 2017 19:54:09 GMT+0000 (UTC)
    19:54:10.223 [pimatic-mobile-frontend] packing static assets
    19:54:10.898 [pimatic-mobile-frontend] packing static assets finished
    19:54:10.911 [pimatic-mobile-frontend] rendering html
    19:54:19.801 [pimatic-mobile-frontend] rendering html finished
    19:54:19.872 [pimatic] Listening for HTTP-request on port 80...
    

    posted in Howto ... read more
  • S
    shgmongo

    @Gleno0h

    I don´t know they are there automaticly. When I copy and paste your
    nano Dockerfile.pimaticnode they are there.

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Tue Jul 11 19:17:11 2017
    pi@raspberrypi:~ $ docker run -t -i -p 80:80 joshendriks/raspberry-pi3-pimatic
    root@c8d71f97adb0:/# 
    root@c8d71f97adb0:/# nano Dockerfile.pimaticnode
    
    

    posted in Howto ... read more

Looks like your connection to pimatic forum was lost, please wait while we try to reconnect.