• S
    S O

    Thank You again, all working now :slight_smile:

    posted in Howto ... read more
  • S
    S O

    This is my current config, is it ok?

    # Default server configuration
    server {
            listen 80 default_server;
            listen [::]:80 default_server;
    
            root /var/www/html;
    
            server_name somename.com;
    
            # Maintain the .well-known directory alias for Let's Encrypt renewals
            location /.well-known {
                    alias /var/www/html/.well-known;
            }
    
            # Redirect to HTTPS
            location / {
                   	return 301 https://$host$request_uri;
            }
            location / {
                    # Proxy requests to pimatic
                    proxy_pass http://127.0.0.1:8080;
            }
    }
    
    # SSL configuration
    server {
            listen 443 ssl default_server;
            listen [::]:443 ssl default_server;
    
            # Let's Encrypt signed certificates
            ssl_certificate     /etc/letsencrypt/live/somename.com/fullchain.pem;
            ssl_certificate_key /etc/letsencrypt/live/somename.com/privkey.pem;
    	ssl_client_certificate /etc/ssl/certs/my_pimatic_CA.crt;
            ssl_verify_client on;
    
    
    
            # Turn on OCSP stapling as recommended at
            # https://community.letsencrypt.org/t/integration-guide/13123
            # requires nginx version >= 1.3.7
            ssl_stapling on;
            ssl_stapling_verify on;
    
            # Uncomment this line only after testing in browsers,
            # as it commits you to continuing to serve your site over HTTPS
            # in future
            add_header Strict-Transport-Security "max-age=31536000";
    
            root /var/www/html;
    
            # Add index.php to the list if you are using PHP
            index index.html index.htm index.nginx-debian.html;
    
            server_name somename.com;
    }
    

    posted in Howto ... read more
  • S
    S O

    Everything else working for me to this point, nginx site needs certificate, after installing certificate lets me in to nginx page, but redirecting to pimatic doesn’t work.

    posted in Howto ... read more
  • S
    S O

    Actually I have same problem, just been busy to troubleshoot this.

    In the end config should look like this? This gives error when trying to reload nginx service.

    # Redirect to HTTPS
            location / {
                    return 301 https://$host$request_uri;
            }
            location / {
                    # Proxy requests to pimatic
                    proxy_pass http://127.0.0.1:8080;
             }
    

    Also, is it necessary to uncomment?
    # add_header Strict-Transport-Security "max-age=31536000";

    posted in Howto ... read more
  • S
    S O

    I think this should include at least “processingTemp”: “$value” as BME280 tend to show couple of degree too high, so it could be calibrated correctly.

    https://github.com/atus/pimatic-bme280/issues/1

    posted in Plugins read more
  • S
    S O

    Also is resend signal removed from RFSwicth on purpose?

    posted in Support in Deutsch read more
  • S
    S O

    What method are you using to get data input into that log? I only found HX711 solutios which worked in terminal.

    posted in Rules and Scripts read more
  • S
    S O

    I use https://somename.asuscomm.com address and used ssl-setup script according wiki.

    But, do I get the certificate for asuscomm.com and not somename.asuscomm.com? Is it ok to run that script again with new name? 0_1500228771106_upload-09a1e7a4-e15f-47b6-92ea-1f815149f25a

    posted in Troubleshooting read more
  • S
    S O

    I’m wondering whats wrong with my settings because getting https not secure when connecting my pimatic from internet. I did the settings according the installation guide. Disabled http and enabled https.

    "httpsServer": {
      "enabled": true,
      "port": 443,
      "hostname": "",
      "keyFile": "ca/pimatic-ssl/private/privkey.pem",
      "certFile": "ca/pimatic-ssl/public/cert.pem",
      "rootCertFile": "ca/certs/cacert.crt"
    },
    

    I was thinking if something wrong when giving dyndns name, which is from my asus modem like somename.asuscomm.com. Another thing that do I have to input something as hostname in the config?
    I can log in but i get security warnings.
    What should I check?

    posted in Troubleshooting read more
  • S
    S O

    I was trying to do this but getting erros after ./certbot-auto:

    Installing Python packages…
    Installation succeeded.
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Failed to find executable apache2ctl in PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot-auto certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.

    Any hints for this?

    posted in Howto ... read more

Looks like your connection to pimatic forum was lost, please wait while we try to reconnect.