@georg90 said in Using NodeJS 7.x:
Are you sure about 4.6? Can I use 4.8 (latest LTS?)?
4.8 is fine, so I should have said 4.x.
4.x is still covered by LTS, however, active LTS will end on 1st of April. Basic Maintainance will contine until 1st of April 2018. When you look at the Node.js site the current LTS version advertised is 6.10. See also https://github.com/nodejs/LTS#lts-schedule
Some of the submodules of the pimatic-hap plugin require node 4.3, I only have 4.2.6 installed.
I wasn’t aware of this as I don’t use pimatic-hap in my setup. Are you sure? I can find it in the docs. The engine spec for HAP-NodeJS states
"node": ">=4.3.2", btw. So, you should get warning message your Node.js is too old.
"It always takes longer than you expect, even when you take into account Hofstadter's Law.", Hofstadter's Law